2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Vitara starting issues


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Starting issues
View previous topic :: View next topic  
Author Message
Retro
***


Joined: 18 Jul 2009
Posts: 154
Location: South Lakes

PostPosted: Mon Dec 21, 2009 19:55    Post subject: Vitara starting issues Reply with quote

Hey Guys how you doing haven't been on for a while  Confused

My x reg 1.6 8v Vitara, is having a few issues starting it was showing all the classic signs of needing a new battery, it wouldn't hold charge for too long and then wouldn't start on the key I could hear a faint whine from the starter so a bump round the corner she fired or a jump start and she fired.

So tonight a new battery arrived, put it on and same again faint whine no start, so bumped it round the corner and went for short spin lights on but nothing else brought it back and it fired up six times on the key happy daze  Cool

Any way just been out again and she wouldn't fire same again faint whine from the starter so bumped it drove round the block and its working on the key again. tried switching everything on heated rear screen ,lights on main beam , radio, heater blower ect  she fired up with all this running then let the starter fire the car up in gear it dragged it along a couple of feet and fired up.

Just tried it again and no fire just the whine from the starter, I did drive through a lot of Cumbrian flooding so am now thing, the starter needs to come off be cleaned up, oiled /greased,  contacts cleaned connections checked, or am I barking up the wrong tree? Just been out 10 mins later and she fired up on the key???
Any ideas chaps as its doing my head in  Mad

Cheers,

Gav.
_________________
There not canoes more of a snorkel and aero aid rolled into one
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Mon Dec 21, 2009 19:55    Post subject: Google Ads keep this community free to join!


Back to top
deathbus
****


Joined: 10 Apr 2009
Posts: 250
Location: probly lyin down

PostPosted: Mon Dec 21, 2009 21:38    Post subject: Reply with quote

vit/sj starters are prone to sticking i hear, mines does it intermitantly  Mad

id say strip it an clean/re-grease an fire it back together.

ive a spare one i keep meaning to get round to overhaulin, never seem to get round to it tho  Embarassed
_________________
if its got t*ts or tyres, its gonna be trouble!!
Back to top
View user's profile Send personal message
Rick-81
*


Joined: 17 Jun 2009
Posts: 34
Location: Doncaster

PostPosted: Mon Dec 21, 2009 21:53    Post subject: Reply with quote

I've just changed mind it was doing the same but when hot not from cold happy to say the new/second hand one is fine so solved it for me!

Hope ya get it sorted mate!  Razz
Back to top
View user's profile Send personal message MSN Messenger
Retro
***


Joined: 18 Jul 2009
Posts: 154
Location: South Lakes

PostPosted: Tue Dec 22, 2009 21:11    Post subject: Reply with quote

Cheers lads, she's been starting on the key all day today, I am starting to think the old battery was goosed and the new one was not fully charged up it's not like the "Spanish build" vit battery is going to be that popular  Rolling Eyes  so could have been sat around a for a while, did clean all the starter contacts up but it was to cold to be scratting around taking it off, so drowned the whole engine bay in WD and went for a drive to the top of Kirkby Fell in south Cumbria not a soul around and mine were the only tyre tracks in the two foot of snow up there  Cool
_________________
There not canoes more of a snorkel and aero aid rolled into one
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Starting issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group