2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Have to leave my car two hours after using it to start it


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Vitara Engine Q&A
View previous topic :: View next topic  
Author Message
liam Roberts
Newbie


Joined: 04 Dec 2013
Posts: 1
Location: Worcester

PostPosted: Wed Dec 04, 2013 13:04    Post subject: Have to leave my car two hours after using it to start it Reply with quote

Hi, I have a suzuki vitara j4u 1.6 carb model 1999
Car starts perfectly In the morning when cold but once used and left for approximately 10 to 15 minutes it won't start until it has been left for an hour and a half to two hours if I turn it off and immediately back on it'll start the maximum time I can leave it for is about 3 minutes and then I have to leave it I have tried to have it diagnosed but it is too old I have changed the distributor but still no change.
Has anyone else had the same problem please let me know as it is driving me mad
Thanks
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Wed Dec 04, 2013 13:04    Post subject: Google Ads keep this community free to join!


Back to top
DavidS
***


Joined: 30 Aug 2012
Posts: 188
Location: Maidstone, Kent

PostPosted: Wed Dec 04, 2013 15:42    Post subject: Reply with quote

Sounds like a fuel problem ... a long time ago I had a car that would cut out when hot ... A diaphragm was faulty ... when car running (driving along) it was just getting enough fuel into the engine, but when idel it would cut out due to temp in engine bay causing the small amount of fuel to evaporate ... when cooled down it would then have enough to start.
_________________
2003 GV1600 Sport Soft Top. Great for Fun in Snow and sun
Back to top
View user's profile Send personal message
Rondec
Newbie


Joined: 06 Nov 2015
Posts: 1

PostPosted: Fri Nov 06, 2015 1:46    Post subject: Reply with quote

Is it turning over but not firing? If so, seems like you need a new crankshaft position sensor. I've had one go on a 97 Subaru liberty and spent hundreds of dollars at many different mechanics who couldn't find the problem.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Vitara Engine Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group