Adrian Flux : 01553 845 945

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

suzuki sj 1.6 8v conversion trouble


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Engines
View previous topic :: View next topic  
Author Message
desired_affect
*


Joined: 01 Apr 2010
Posts: 49
Location: ipswich

PostPosted: Sun Apr 07, 2013 17:51    Post subject: suzuki sj 1.6 8v conversion trouble Reply with quote

right so ive done my 1.6 conversion and im now at the point of firing it up.

it has all my old 1.3 manifolds as the 1.6 was a injection engine so is running with the 1.3 carb, inlet manifold, dizzy and exhaust manifold.

i turn the key and she starts up great but runs at 2000rpm, ive read the haynes manual i cant find the idle screw for love nor money from whats written in there.

the big problem is tho the water temp shoots up and there is white smoke (steam) from the exhaust, the guy the engine came from swears the engine was fine when it came out of the car, to me its screaming blown head gasket does any one have any other ideas i should peruse first?
Back to top
View user's profile Send personal message MSN Messenger
Google
Sponsor





PostPosted: Sun Apr 07, 2013 17:51    Post subject: Google Ads keep this community free to join!


Back to top
me and the wife
*******


Joined: 07 Aug 2007
Posts: 1013
Location: gosport

PostPosted: Mon Apr 08, 2013 6:53    Post subject: Reply with quote

check or remove the thermostat, the carb has an auto choke so it will take a while to throttle down,
Back to top
View user's profile Send personal message
desired_affect
*


Joined: 01 Apr 2010
Posts: 49
Location: ipswich

PostPosted: Mon Apr 08, 2013 17:02    Post subject: Reply with quote

i dont think its the thermostat but i will check it, the only reason i say that is its the same one that i knew was working with the last engine.

could it possibly be the gasket on the inlet manifold sucking in fuel and also sucking in water?
i will also check the water pump.
Back to top
View user's profile Send personal message MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Engines All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group