All Wheel Drive Club

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

GRAND VITARA HELP PLEASE


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> General technical Q&A
View previous topic :: View next topic  
Author Message
mong
Newbie


Joined: 17 Dec 2012
Posts: 2
Location: guisborough

PostPosted: Wed Dec 19, 2012 10:09    Post subject: GRAND VITARA HELP PLEASE Reply with quote

Hi all,

firstly, huge thanx for even taking the time to look at this.

we went away from 4x4 a long time ago ( bad decision ) and we have decided to start again. so we have bought a 2002 GV1600.

but to say things have changed !!!

i want to give the car a good run over the winter just to get a good feel for it and climb hat i fear will be a steep learning curve. however.

out first real 'outing' in it last night and im unsure if all is well under it?

can some one tell me where the 4wd light it on the dashboard?? and what is the most likley fault if its not coming on?

the outing i fear was not taxing enough to show if the 4wd was not working. so how would you suggest i test properly??

also ( huge thanks again ) can someone provide a model number engine code etc so that i can search more information myself

many thanks

tony and ashley  Embarassed
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Wed Dec 19, 2012 10:09    Post subject: Google Ads keep this community free to join!


Back to top
DavidS
***


Joined: 30 Aug 2012
Posts: 188
Location: Maidstone, Kent

PostPosted: Thu Dec 20, 2012 11:04    Post subject: Reply with quote

Hi Guys,Welcome.

I have a GV1600 2003 sport.
when I have engaged 4wd there is a light that flashes up above the speedo rev counter cluster.

I can't give you much more info about anything else as I am finding things out about the car also.
_________________
2003 GV1600 Sport Soft Top. Great for Fun in Snow and sun
Back to top
View user's profile Send personal message
olly84
*


Joined: 16 Apr 2013
Posts: 12
Location: crewe cheshire

PostPosted: Wed May 01, 2013 23:43    Post subject: Reply with quote

Hi im new to this myself but I notice with my gv 1600 if in 4wd and turn steering on full lock then drive slowly forward the car seems to crab very slightly only in 4wd I know a guy with the same gv and his dose the same so I gess this is normal  Question  anyway it only dose it in 4wd so try it out  Smile
Back to top
View user's profile Send personal message
Stevied
Newbie


Joined: 22 Oct 2013
Posts: 4
Location: United Kingdom

PostPosted: Tue Oct 22, 2013 22:24    Post subject: Reply with quote

Hi.

Mine has a green 4WD light on the right hand side of the instrument cluster.
Also like previous post says, full lock and it should crab when crawling forward.
Are you changing to 4WD while the car is in motion? if so, try selecting 4WD while car is stationary.
Says in manual to try this method if 4WD does not engage.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> General technical Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group