4x4 Mart magazine discount

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Vitara 1.6 8v running problems


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Vitara Engine Q&A
View previous topic :: View next topic  
Author Message
Fuzz
Newbie


Joined: 15 Dec 2012
Posts: 2
Location: Derbyshire

PostPosted: Sat Dec 15, 2012 19:14    Post subject: Vitara 1.6 8v running problems Reply with quote

Right, where to begin.

I bought my Suzuki about a month ago. It had been stood for approximately a year and moved on occasion.
Since I have had it, it has had a bit of a hesitation/juddering problem
When cold and you pull away it is almost like it is running on fumes. Very juddery and none responsive. If you blip the throttle with the clutch down and then pull of with 1500ish revs it will be ok. It also suffers on full acceleration. It won't rev up properly and hesitates quite badly. Much to the point where if you don't lift off the throttle it would come to a stop. If, however, you lift off and try at, say, 80 percent throttle it will run fine. I have searched a few posts and came to a few conclusions. None of which however have cured it. So far I have;
Carried out an engine service (fuel, air and oil filters and spark plugs.)
Changed the HT leads as one was shorting out
Removed and cleaned the EGR valve and connecting hoses.
Removed the inlet pipe from the carb and tried the old trusty carb cleaner and full revs to blow out any carbon.
Replaced the thermostat as it was permanently running cold. (On a second note where abouts on the temp gauge is "normal" running temperature. Mine seems to be about a quarter but I would have thought it should be about half way??)

I think the next items to change are the dizzy cap and rotor arm, coil pack and check the fuel pump wire to the rear as I have read somewhere. (I assume this is relevant to my car)
Does anyone have any further suggestions as to what it might be as it is driving me nuts!
Thanks for reading my ramble, and thanks in advance for any advice

Joe
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Sat Dec 15, 2012 19:14    Post subject: Google Ads keep this community free to join!


Back to top
me and the wife
*******


Joined: 07 Aug 2007
Posts: 1013
Location: gosport

PostPosted: Sat Dec 15, 2012 19:35    Post subject: Reply with quote

bin the carb, they are carp. get yourself a su hiff 44 carb and an adaptor kit  Very Happy
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Vitara Engine Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group