4x4 Mart magazine discount

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Jimny - now electrics at all.


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Electrics / wiring / lights etc
View previous topic :: View next topic  
Author Message
Henry V
Newbie


Joined: 12 Feb 2012
Posts: 1
Location: Oxford

PostPosted: Sun Feb 12, 2012 13:54    Post subject: Jimny - now electrics at all. Reply with quote

Hello!

Jimny has been great in the recent snow, parked it up yesterday, went to start it today and there's no electrics of any sort, no radio, lights, central locking, nothing on the dash.

What's likely to be the cause of this? I've check the battery connections and they look fine.

Any help would be much appreciated!  Very Happy
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Sun Feb 12, 2012 13:54    Post subject: Google Ads keep this community free to join!


Back to top
deathbus
****


Joined: 10 Apr 2009
Posts: 250
Location: probly lyin down

PostPosted: Sun Feb 12, 2012 23:30    Post subject: Reply with quote

first check battery voltage with a multimeter, cold weather kills batteries.

next fuses, particularly the high amp ones.

did you have any unusual lights on in the instrument cluster prior to parking it up?
_________________
if its got t*ts or tyres, its gonna be trouble!!
Back to top
View user's profile Send personal message
2old2tired2scared
Lifetime member
Lifetime member


Joined: 06 Jul 2010
Posts: 357
Location: glos

PostPosted: Mon Feb 13, 2012 11:41    Post subject: Reply with quote

I would guess its the teeny weeny battery. I need a new one, am currently jumpstarting every
morning  Sad .(has never been the same since it was parked up for a week !)
When the battery has had enough there's little you can do but replace it.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Electrics / wiring / lights etc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group