4x4 & MPV Driver - 40% subscription discount

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

water temp


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Cooling system
View previous topic :: View next topic  
Author Message
Rich
*


Joined: 13 May 2010
Posts: 35
Location: CORNWALL

PostPosted: Tue Jan 25, 2011 20:07    Post subject: water temp Reply with quote

The temp guage in the my Vit doesn't move........changed the sensor checked the thermostat...........engine gets to operating temp..........minimal amount of warmth in the cab.....can hear what sounds like water rushing through it, might be air. Its been like this since well before the winter......anyone got any ideas what to do next. Replaced the water pump too. Cheers Richard
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Tue Jan 25, 2011 20:07    Post subject: Google Ads keep this community free to join!


Back to top
popuptoaster
***


Joined: 10 Nov 2010
Posts: 192
Location: Essex

PostPosted: Tue Jan 25, 2011 20:46    Post subject: Reply with quote

might have an airlock in the sytem, possibly in the heater if you can hear it inside.
Back to top
View user's profile Send personal message
Rich
*


Joined: 13 May 2010
Posts: 35
Location: CORNWALL

PostPosted: Tue Jan 25, 2011 20:51    Post subject: cheers Reply with quote

cheers will start by giving it a flush tomorrow  Laughing
Back to top
View user's profile Send personal message
Rich
*


Joined: 13 May 2010
Posts: 35
Location: CORNWALL

PostPosted: Tue Mar 15, 2011 19:05    Post subject: head gasket Reply with quote

Flushed the system and the problem got worse when the girlfriend took the Vit over 70mph and frothed the water all over the engine bay......the bubbles I could hear going round the heater matrix were due to the head gasket going. Got the head skimmed and replaced the gasket and now I have heat in the cab and the temp gauge works and no bubbles. Just in time for the warmer weather  Rolling Eyes ......Cheers for the advice Smile
Back to top
View user's profile Send personal message
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Tue Mar 15, 2011 20:24    Post subject: Reply with quote

lets see...

you asked for advice then your girlfriend took the car and boiled it up.

you gave minimal symptoms and then complained about the outcome.

give people a fair crack of the whip and theyll help but you cant expect miracles.

how do you expect people to diagnose your cars fault when they havent seen it and you dont describe it very well

or if you were genuine in your thanks, glad you got it sorted and apologies for snapping but theres a muppet creeping round here somewhere upsetting us old hands Sad
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
Rich
*


Joined: 13 May 2010
Posts: 35
Location: CORNWALL

PostPosted: Tue Mar 15, 2011 20:38    Post subject: sorry bud Reply with quote

I was serious about the thanks for the recommendation of flushing the radiator system it was a good place to start.......but on reading the reply from me it doesn't read well on my behalf....VERY SORRY........I blame the girlfriend and 70mph for frying the blessed thing and my poor description of the fault....at the beginning it was just a small amount of bubbles until she drove it........NEVER AGAIN will she sit in the right hand side.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Cooling system All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group