Adrian Flux : 01553 845 945

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

2.0 v6 idleing high


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Engines
View previous topic :: View next topic  
Author Message
lincsuki
*


Joined: 16 Jan 2011
Posts: 31
Location: holbeach lincs

PostPosted: Fri Jan 21, 2011 19:02    Post subject: 2.0 v6 idleing high Reply with quote

Hi my 2.0 v6 vit ive just bought is idleing at 1200 rpm and eventualy drops to no less than 1000, sometimes it fluctuates from 1200 to 2000.
Has anybody had this problem or know what it could be?
Is there an idle stabiliser valve somewhere that it could be?

Cheers
Lloyd
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Fri Jan 21, 2011 19:02    Post subject: Google Ads keep this community free to join!


Back to top
Tallbike
***


Joined: 11 Jan 2011
Posts: 180
Location: Eastbourne

PostPosted: Sat Jan 22, 2011 20:11    Post subject: Reply with quote

Had a similar problem on an Escort I sold a few months ago, my mechanic said it could be a temperature sensor... I don't know if this would be the same on the V6 as I had one before... but never had a problem with it! Hope this helps find the real solution! Very Happy
_________________
Driving a 99' Vitara JX 4U2...
Now in black
2" body lift & 2" suspension lift
31" MT tyres
Matching trailer being built from a 5 door Vit, watch this space!
Back to top
View user's profile Send personal message
lincsuki
*


Joined: 16 Jan 2011
Posts: 31
Location: holbeach lincs

PostPosted: Mon Jan 24, 2011 18:41    Post subject: Reply with quote

I had the same problem on my golf gti and on that it was the idle stabiliser valve.
The trouble is I'm new to suzuki and don't really know where to start looking , I've found a water controlled unit on top of the throttle body but that seems to operate ok.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Engines All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group