4x4 & MPV Driver - 40% subscription discount

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

heelp my v6 vit just overheated!!!1


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Cooling system
View previous topic :: View next topic  
Author Message
lincsuki
*


Joined: 16 Jan 2011
Posts: 31
Location: holbeach lincs

PostPosted: Fri Jan 21, 2011 18:59    Post subject: heelp my v6 vit just overheated!!!1 Reply with quote

I seem to have a problem thats baffled me with my 2.0 v6 vit.
when driving it the temp gauge sits perfectly in the middle and heating works fine etcetc blah blah.
The problem is i have just sat in traffic on the A1 for an hour and it had an epic overheat and dumped all of its water out as steam from the drain pipe on the expansion bottle.

could this be down to a dodgy viscous coupling? the fan seems to spin very freely by hand.
And would i be ok to just fit an electric fan to the rad?
I filled it back up with water and made the hour drive back home with no problems at all.

any help would be greatfully appreciated
cheers
Lloyd
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Fri Jan 21, 2011 18:59    Post subject: Google Ads keep this community free to join!


Back to top
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Sat Jan 22, 2011 9:37    Post subject: Reply with quote

check your thermostat is working...
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
lincsuki
*


Joined: 16 Jan 2011
Posts: 31
Location: holbeach lincs

PostPosted: Mon Jan 24, 2011 18:28    Post subject: Reply with quote

Surely if my stat was dodgy then it wouldn't sit in the middle of the temp gauge under normal use
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Cooling system All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group