2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

89 vitara running issues


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Starting issues
View previous topic :: View next topic  
Author Message
oz_votara
Newbie


Joined: 25 Oct 2010
Posts: 6
Location: Australia

PostPosted: Mon Oct 25, 2010 5:28    Post subject: 89 vitara running issues Reply with quote

i have a 89 vitara g16a & ive replaced the carbie & pump & filter& spark plugs & leads, ive flushed the fuel tank & lines too, replaced the air filter & yet when its driving after a few minutes it does notwant to hardly run & dies & splutters. i took the dizzy & coil to a electrician & he said they seem good with a bright spark, im sick of spending money & having the problem still there though. any ideas?
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Mon Oct 25, 2010 5:28    Post subject: Google Ads keep this community free to join!


Back to top
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Mon Oct 25, 2010 7:48    Post subject: Reply with quote

try cleaning out the breather from the engine, it might be pressurising if your rings area little worn
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
oz_votara
Newbie


Joined: 25 Oct 2010
Posts: 6
Location: Australia

PostPosted: Tue Nov 02, 2010 11:52    Post subject: ? Reply with quote

zocko wrote:
try cleaning out the breather from the engine, it might be pressurising if your rings area little worn

how could the breather do that? theres no pressure in there as it breathes into the air filter.
Back to top
View user's profile Send personal message
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Mon Nov 08, 2010 14:57    Post subject: Reply with quote

and if its blocked, the pressure builds up in the block if the rings are a bit sloppy or into the rocker box if the stem seals are worn
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Starting issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group