2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Help. Filling radiator, water pours straight into sump.


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki LJ / SJ Engine Q&A
View previous topic :: View next topic  
Author Message
cheesecake13
Newbie


Joined: 20 Nov 2018
Posts: 2
Location: Suffolk

PostPosted: Tue Nov 20, 2018 21:20    Post subject: Help. Filling radiator, water pours straight into sump. Reply with quote

Hi all.

I have bought an 86/87 SJ410 that has not run for many years. After doing the usual recommissioning work she fired up and ran nicely. Next I decided to fill the cooling system to check for leaks. The water in the radiator got to near the top then just disappeared. I could actually hear the water pouring into the sump  Shocked. I drained the oil and water systems, removed and cleaned all the water side parts, pulled the heads, cleaned and changed all components and replaced head gasket, intake gasket and water pump gasket.
After all that I fired up the engine again and it runs lovely. Started filling the radiator with fingers crossed but it did the same thing, just poured into the sump almost as quickly as I could pour it in. The leak is so fast that I'm sure it's not the head gasket or the intake gasket and for a crack to allow that much water flow I would have thought the motor would run like carp or not at all.
I'm all out of ideas.
Please help.
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Tue Nov 20, 2018 21:20    Post subject: Google Ads keep this community free to join!


Back to top
cheesecake13
Newbie


Joined: 20 Nov 2018
Posts: 2
Location: Suffolk

PostPosted: Wed Nov 21, 2018 12:58    Post subject: Reply with quote

All sorted now. If anyone is interested, the problem was a popped freeze plug in the head under the cam shaft.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki LJ / SJ Engine Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group