2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Escudo/Vitara 1990 electrical problem - help needed!


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Electrics / wiring / lights etc
View previous topic :: View next topic  
Author Message
Richardds
Newbie


Joined: 08 Jan 2014
Posts: 1
Location: Kent

PostPosted: Thu Mar 06, 2014 10:50    Post subject: Escudo/Vitara 1990 electrical problem - help needed! Reply with quote

Hi
Recently acquired a 1990 Escudo. When purchased Alternator identified as not working, re-con fitted. Subsequently new battery and then cable between alternator and battery + connector at back of alternator replaced. Fine for about a month, but problem has started again.
The battery warning light on the dash lights up when ignition on but goes out on engine starting (as would usually expect), but does not come to warn of problems!!
Anyone had previous experience or got any suggestions??
Many thanks
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Thu Mar 06, 2014 10:50    Post subject: Google Ads keep this community free to join!


Back to top
denbo
**


Joined: 16 Dec 2011
Posts: 104
Location: doncaster

PostPosted: Sun Mar 09, 2014 12:02    Post subject: Reply with quote

EH, i dont understand. Key on, bat light illuminates. Start engine, light extinguishes. All good, so where is the problem?
Back to top
View user's profile Send personal message
DavidS
***


Joined: 30 Aug 2012
Posts: 188
Location: Maidstone, Kent

PostPosted: Sun Mar 09, 2014 22:56    Post subject: Reply with quote

sometimes the alternator is working but just not producing quite enough to charge the battery so no 'error' light will come on
_________________
2003 GV1600 Sport Soft Top. Great for Fun in Snow and sun
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Electrics / wiring / lights etc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group