Adrian Flux : 01553 845 945

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Starter Motor


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Starting issues
View previous topic :: View next topic  
Author Message
silverstone
Newbie


Joined: 17 Aug 2011
Posts: 3
Location: Wakefield

PostPosted: Sun May 19, 2013 8:26    Post subject: Starter Motor Reply with quote

Ive had a whine coming from the starter motor on my 2004 2.0td G vit, then over a few weeks it got slower until I thought the battery was letting go, one new 90amp battery later, same prob, then the other day I tried starting, turned the key everything came on as usual, second turn of the key, nothing, not even a click, following day tried it, turned over no problem, so it took it in to local garage for testing, battery 4 weeks old all good, alternator good, no power drain from anywhere, (meter was left on overnight), mechanic says he cant find anything wrong with it, two weeks on without probs & its done the same again, my question is, is the starter easy to access & is it a quick whip it off & on if I get a replacement or could it be an ignition barrel fault, I`m beginning to lose faith, please help !!
Mitch
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Sun May 19, 2013 8:26    Post subject: Google Ads keep this community free to join!


Back to top
silverstone
Newbie


Joined: 17 Aug 2011
Posts: 3
Location: Wakefield

PostPosted: Mon Jun 24, 2013 19:00    Post subject: Reply with quote

It was the starter after all, chucked a new one on & all is well !!!
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Starting issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group