All Wheel Drive Club

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Starting problem


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Samurai Engine Q&A
View previous topic :: View next topic  
Author Message
stevencummings35
Newbie


Joined: 20 Sep 2011
Posts: 6
Location: United States

PostPosted: Tue Sep 20, 2011 15:42    Post subject: Starting problem Reply with quote

Ive got an 87 Sammi, everything runs great except when i turn the ignition i have to push the accelerator all the way down in order to start it. Any ideas on a fix?
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Tue Sep 20, 2011 15:42    Post subject: Google Ads keep this community free to join!


Back to top
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Tue Sep 20, 2011 15:47    Post subject: Reply with quote

do you mean when its hot or cold or both?
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
stevencummings35
Newbie


Joined: 20 Sep 2011
Posts: 6
Location: United States

PostPosted: Tue Sep 20, 2011 15:50    Post subject: Starting problem Reply with quote

only when its a cold start. Glow plugs maybe?
Back to top
View user's profile Send personal message
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Tue Sep 20, 2011 16:00    Post subject: Reply with quote

it will only have glow plugs if its a diesel.

the original carb has an auto choke but you need to activate manually if that makes sense.

try pumping the gas pedal 3 times before you turn the key. itll activate the choke and should make it easier to start.
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Samurai Engine Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group