All Wheel Drive Club

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Clicking when i turn the key but no start??


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Electrics / wiring / lights etc
View previous topic :: View next topic  
Author Message
MrGreenytwins
*


Joined: 19 Jan 2011
Posts: 10
Location: Leicestershire

PostPosted: Thu Apr 21, 2011 7:42    Post subject: Clicking when i turn the key but no start?? Reply with quote

Hi Guys,

theres a Clicking in my Vit when i turn the key? this prevents me from starting. when the clicking eventually stops my vit starts. the clicking is coming from the inlet manifold and the vacuum sensor.. when i un plug the vacuum sensor it still clicks in the manifold.. i have changed the relays under the steering colume ( 1of those clicks sometimes aswell) but i cant seem to find the exact fault and stop the clicking.. has anybody had this problem or can anybody help?
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Thu Apr 21, 2011 7:42    Post subject: Google Ads keep this community free to join!


Back to top
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Thu Apr 21, 2011 16:40    Post subject: Reply with quote

sounds like maybe a bad starter?

is the clicking coming from the starter solenoid by any chance?
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
MrGreenytwins
*


Joined: 19 Jan 2011
Posts: 10
Location: Leicestershire

PostPosted: Fri May 06, 2011 21:09    Post subject: Reply with quote

hi ya bud, the clicking is coming from the relay under the steering column, which follows through to the vacuum sensor,? i have put a new starter motor on her aswell.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Electrics / wiring / lights etc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group