Adrian Flux : 01553 845 945

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Vitara Hazard Switch stopped working


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Electrics / wiring / lights etc
View previous topic :: View next topic  
Author Message
Molesy
Newbie


Joined: 08 Mar 2011
Posts: 3

PostPosted: Sun Mar 27, 2011 16:22    Post subject: Vitara Hazard Switch stopped working Reply with quote

Hi, I have a 4u '98 Vitara and the hazard switch on top of the steering column has stopped working. I still have indicators left/right. I've taken the steering column apart thinking I could just replace the switch but it doesn't look possible.  

Can anyone help please diagnose if the switch is faulty and give advise how to remove/replace? I cannot find anything on the net having googled for hours.

Thanks,
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Sun Mar 27, 2011 16:22    Post subject: Google Ads keep this community free to join!


Back to top
Molesy
Newbie


Joined: 08 Mar 2011
Posts: 3

PostPosted: Fri Apr 01, 2011 19:31    Post subject: Reply with quote

Hi all, I know this was my first post but I hope it not to be my last and wish to help and contribute. But this switch is driving me nuts. So if anyone can help or point me in the direction of help it would be appreciated. Thanks.
Back to top
View user's profile Send personal message
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Sat Apr 02, 2011 7:45    Post subject: Reply with quote

it could just be that the switch has died.

if you need to replace it, its a complete stalk assembly im afraid Sad
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
Molesy
Newbie


Joined: 08 Mar 2011
Posts: 3

PostPosted: Sun Apr 03, 2011 21:30    Post subject: Reply with quote

Zocko, thank you for response. I thought it might be the chase, looking at it. I was thinking of creating a new switch and running the cables elsewhere. Do you know if this is possible, easy and where I could get the wiring diagram to do it?

Thanks again.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Electrics / wiring / lights etc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group