Adrian Flux : 01553 845 945

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

My little Vitara's poorly! HELP


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Engines
View previous topic :: View next topic  
Author Message
r1mmer
*


Joined: 07 Dec 2010
Posts: 20
Location: Darlington

PostPosted: Tue Dec 07, 2010 18:41    Post subject: My little Vitara's poorly! HELP Reply with quote

hi all, im totally new to forums and 4x4's so bear with me....

I got a little 1995 vitara 1.6 16v jlx a few days ago and when i got it, it was very flat, spluttery and drank the petty. Sometimes when i pull up at traffic lights etc, the revs drop right down (bearly on the clock) and sometimes cuts out.  I just persumed she needed a good service.

I got the plugs done today and its made it a little better but its still canny flat and drinks the fuel and a bit spluttery. I also got just fuel additive to give the fuel system a good clean. the revs dont drop as low but they go down, then up, then down etc when sat still. Im planning on changing the air filter and fuel filter in a few days.

Im no mechanic so i was wondering if anyone has any info, possable causes or any things to check or change. ive read alot on here about similar problems but theres just so many causes and i know know were to start. She was supposed to be a little toy for the snow while my focus ST rep hibernated but it looks like i wont get out much.

Any advice welcome =D
Back to top
View user's profile Send personal message MSN Messenger
Google
Sponsor





PostPosted: Tue Dec 07, 2010 18:41    Post subject: Google Ads keep this community free to join!


Back to top
r1mmer
*


Joined: 07 Dec 2010
Posts: 20
Location: Darlington

PostPosted: Mon Dec 13, 2010 23:14    Post subject: Reply with quote

just thort id add a little message if anyone is having any similar problems.

after changing the spark plugs, nothing really changed. i checked the tyre pressure and they only had about 20psi in so i filled them up. i noticed the diff locks were on as well so i turned them to free. she was loads better. nicer to drive, way better on fuel and abit nippier. i then changed the rotor arm and cleaned up the dizzy cap (i bought the wrong 1) but still missin abit. when i checked the leads (with the engine running) i noticed the sparks coming out of the sides so there next on the list to do. i still havnt serviced her and shes running pretty well, carnt wait to get it done.

the leads look like the original ones, the old plugs were jet black, dizzy cap and rotar arm were filthy and the screws on the airbox have corroded badly so it looks like she hasnt been serviced in a long, long time.
Back to top
View user's profile Send personal message MSN Messenger
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Tue Dec 14, 2010 8:15    Post subject: Reply with quote

glad you got it sussed
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Engines All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group