2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Grand Vitara engine problem


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Vitara Engine Q&A
View previous topic :: View next topic  
Author Message
3531andrew
Newbie


Joined: 05 Dec 2010
Posts: 2

PostPosted: Sun Dec 05, 2010 15:31    Post subject: Grand Vitara engine problem Reply with quote

Can anyone out there help. My 1998 2L diesel has just developed an engine probem. Driving along yesterday the engine lost power I kept my foot to the floor but it would not go above 1500rpm and when I looked on the dash the filter trap light was on . I got the car home and though change the filter and away we go. New filter fitted still the same. I primmed the filter by filling it up with fuel and then srewing into the housing. The car starts and seems ok for a few seconds and then the problem of low revs is apparant. If I take the filter back off the filter is not full and I have also checked that fuel is coming down the feed pipe from the tank so I dont think there is any blockage there. Also I noticed that when the car is runnuing if I open the bleed srew on the filter housing there is no fuel coming out which you would expect. I have asked a few questions with people I know and I have told various answers such as; fuel blockage from tank, pump not working, (but I cannot find a pump apart from injector pump) does it have a pump in tank?. I would love help with this chaps so do you have the answer? Sad  Sad .
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Sun Dec 05, 2010 15:31    Post subject: Google Ads keep this community free to join!


Back to top
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Mon Dec 06, 2010 12:49    Post subject: Reply with quote

sounds like either the pump in your tank is getting lazy or theres a pin hole somewhere in the fuel line and its syphoning air ito it?

what pressure do you have from the lift pump?
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
3531andrew
Newbie


Joined: 05 Dec 2010
Posts: 2

PostPosted: Mon Dec 06, 2010 16:58    Post subject: Reply with quote

I have been told that there is not a pump in the tank and this model does not have a lift pump,so Iam getting rather confused at the moment. if I suspect that there is a pump in the tank then I would take the tank off but its not an easy job so I need to know if there is a pump in the tank. Can anyone confirm?
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Vitara Engine Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group