All Wheel Drive Club

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

engine lack of power/misfire.....help please!!!!


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Engines
View previous topic :: View next topic  
Author Message
jimmy_fiddler
Newbie


Joined: 21 Dec 2009
Posts: 1
Location: Bristol

PostPosted: Mon Dec 21, 2009 20:14    Post subject: engine lack of power/misfire.....help please!!!! Reply with quote

hi guys, i have a suzuki sj413 with a 1.6 8v carb engine from a vitara.
Recently i have been having issues with the running of the car....
for example under load when accelerating i get a very strong hesitation then appears to start misfiring. the car loses power and will not go above 2,000rpm.
i initially replaced the spark plugs, leads, dizzy cap and arm as these had all seen better days. this made no difference.
i then checked a website out that said that when the fuel pumps were failing you have symptoms that matched my description.
so i replaced the fuel pump, this made an improvment briefly then reverted back to its old ways.Mad
now i can drive it for a few miles and its fine then it will start misifring, if i rev the engine hard the hesitation goes away and all seems well, this is leading me to believe it may be a fuelling issue?!?!?!

has any1 had this kind of problem or similar or can any1 help please????

cheers the fiddler
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Mon Dec 21, 2009 20:14    Post subject: Google Ads keep this community free to join!


Back to top
deathbus
****


Joined: 10 Apr 2009
Posts: 250
Location: probly lyin down

PostPosted: Mon Dec 21, 2009 21:31    Post subject: Reply with quote

have you changed the fuel filter?

if not, id try that  Wink
_________________
if its got t*ts or tyres, its gonna be trouble!!
Back to top
View user's profile Send personal message
RSi
*


Joined: 12 Dec 2009
Posts: 46
Location: Outer Hebrides

PostPosted: Tue Dec 22, 2009 9:10    Post subject: Reply with quote

I'd try the fuel filter too before anything else, sounds like fuel starvartion when it needs it most.
_________________
2004 2.0L Petrol Grand Vitara LWB
Back to top
View user's profile Send personal message
tackleall
Newbie


Joined: 11 May 2010
Posts: 3
Location: north norfolk

PostPosted: Tue May 11, 2010 18:54    Post subject: Reply with quote

souncs like the carb cannot supply the fuel through the accelerator pump  had prblems with my vitara found it to be bearing on distributor shaft
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Engines All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group