2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

losing water from expansion tank


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> General technical Q&A
View previous topic :: View next topic  
Author Message
thomas
Newbie


Joined: 04 Nov 2009
Posts: 7
Location: redruth cornwall

PostPosted: Sun Jan 31, 2010 10:51    Post subject: losing water from expansion tank Reply with quote

i have a 1996 vitara jlx se 16v. I have replaced water pump after overheating problems and does,nt overheat anymore but seems to lose water from expansion tank every couple of days it needs filling up although there are no signs of leaks and the radiator is always full. Can anyone help.
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Sun Jan 31, 2010 10:51    Post subject: Google Ads keep this community free to join!


Back to top
seeyoujimny
*


Joined: 30 Dec 2009
Posts: 19
Location: Dundee

PostPosted: Sun Jan 31, 2010 11:16    Post subject: Reply with quote

hi thomas, welcome to the club, ok, so the coolant has to be going somewhere, you say it overheated? if they have aluminium heads, ( i cant sy for sure) they will be prone to warping under excessive heat, if they warp they can burn coolant et, so it might be worth while pressure testing the coolant system, when its hot and when its cold, whats the engine oil like? Does the radiator cap fit ok, seal good etc? expansion tank can be cracked without you noticing, again, usually a symptom of overheating, could try getting one out the scrappies, they might not be expensive new anyway? check all the hose connections, and the water pump, they have a tell tale hole underneath if the seal is not working, coolant will leak out. is not uncommon or new parts to fail!
you usually need to keep toping up the coolant after a repair anyway, till it finds its own level, but it shouldnt take long! does the heater work? also you could drain off a little bit of engine oil to see if there is any water in the sump, only if you cant find a visable leak. hope this helps you,
Good luck
Back to top
View user's profile Send personal message
thomas
Newbie


Joined: 04 Nov 2009
Posts: 7
Location: redruth cornwall

PostPosted: Sun Jan 31, 2010 11:27    Post subject: losing water from expansion tank Reply with quote

when it use to get hot it did,nt go into the red, just higher than it should. Oil is clean and heater is very good.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> General technical Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group