2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

OVER FUELING


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Vitara Engine Q&A
View previous topic :: View next topic  
Author Message
BJWAKER
Newbie


Joined: 18 Jan 2010
Posts: 2
Location: SOUTHEND ON SEA

PostPosted: Mon Jan 18, 2010 22:01    Post subject: OVER FUELING Reply with quote

Can anyone HELP PLEASE , I have a 2000 w VITARA 1.6 8v single point injection that just poors fuel in , emmissions for MOT off the scale , I thought it may be electronic so took to my dealer who said ` plugs, cap + leads required ( HA HA ) all systems supposedly fine when diagnostic carried out ! I have since cheked sensors etc to the best of my ability with ohm meter and readings from manual .
I have also fitted a fuel pressure regulator with gauge incase that was the fault but to no avail .
With no mot my ride is useless and I am very frustrated .

Any suggestions ?????
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Mon Jan 18, 2010 22:01    Post subject: Google Ads keep this community free to join!


Back to top
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Tue Jan 19, 2010 19:27    Post subject: Reply with quote

have you tried cleaning the injector?

look under the air inlet pipe into the manifold and youll see what looks like a carb, in the middle of this is the injector.

you can get an aerosol carb cleaner from any motor factors, just spray a little of that around the injector when it isnt running and let it evaporate.

you can also do this around the air flow sensor if you have one??? this might be the cause.
_________________
the car in front is a toyota...

the car pulling it out of the mud is a suzuki
Back to top
View user's profile Send personal message
BJWAKER
Newbie


Joined: 18 Jan 2010
Posts: 2
Location: SOUTHEND ON SEA

PostPosted: Tue Jan 19, 2010 20:24    Post subject: Reply with quote

Thanks ill give that a try at the weekend and get back to you .
B.
Back to top
View user's profile Send personal message
Lip_ripper00
*


Joined: 05 Nov 2009
Posts: 24
Location: Vancouver BC Canada

PostPosted: Wed Jan 20, 2010 8:24    Post subject: Reply with quote

"normally" when it over fueling with a TBFI the computer is being told it's cold. I would look again at the temp sensors their are 2 and see what happens
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Suzuki Vitara Engine Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group