4x4 Mart magazine discount

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Vitara running cold???


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> General technical Q&A
View previous topic :: View next topic  
Author Message
bamberz
Newbie


Joined: 23 Nov 2009
Posts: 3
Location: Aberdeenshire

PostPosted: Mon Nov 23, 2009 19:00    Post subject: Vitara running cold??? Reply with quote

My viitara is running cold, i have tried a new thermstat in it but it doesnt make any difference! the top radiator hose is hot but the bottom hose is only luke warm. any ideas? would help alot if anyone knows as its not the best time of year to not have the heat
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Mon Nov 23, 2009 19:00    Post subject: Google Ads keep this community free to join!


Back to top
me and the wife
*******


Joined: 07 Aug 2007
Posts: 1013
Location: gosport

PostPosted: Mon Nov 23, 2009 19:25    Post subject: Reply with quote

they do run quite cold this time of year as the fan is always spinning and your up north, you could buy an electric fan kit so the fan would only run when the engine is hot Very Happy
Back to top
View user's profile Send personal message
bamberz
Newbie


Joined: 23 Nov 2009
Posts: 3
Location: Aberdeenshire

PostPosted: Mon Nov 23, 2009 20:39    Post subject: Reply with quote

think its running a little too cold though it doesnt move much further than the first notch
Back to top
View user's profile Send personal message
me and the wife
*******


Joined: 07 Aug 2007
Posts: 1013
Location: gosport

PostPosted: Tue Nov 24, 2009 8:40    Post subject: Reply with quote

try running the engine and stopping the engine fan then watch the temp it should raise and give you heat in the cab
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> General technical Q&A All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group