2Gether FS : 01945 585322

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

auto transmission


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Gearbox / transmission
View previous topic :: View next topic  
Author Message
trigg
Newbie


Joined: 02 Nov 2009
Posts: 3
Location: south wales

PostPosted: Wed Nov 04, 2009 9:39    Post subject: auto transmission Reply with quote

alittle confused bought a vitara on a h plate for £225 all worked fine then had problem with gearbox leaking trany oil replaced gasket still seping
if i go offroading with our club dulaisvalley4x4.co.uk  and start to climb a hill put it ino first start to climb then it drops out of gear check oil all is ok not sure if torque converter is faulty
will / can take out box but got no plans to work too or check or overhaul gear box any suggestions help please got a manual box but been told stick with auto
need help or advise thankyou  Very Happy
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Wed Nov 04, 2009 9:39    Post subject: Google Ads keep this community free to join!


Back to top
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Wed Nov 04, 2009 18:52    Post subject: Reply with quote

sounds like you need to check your selector maybe?

is it locking into gear properly?
Back to top
View user's profile Send personal message
trigg
Newbie


Joined: 02 Nov 2009
Posts: 3
Location: south wales

PostPosted: Thu Nov 05, 2009 13:49    Post subject: locking in gear Reply with quote

locking in fine just droping out of gear as if no oil when going up steap hills once at the bottom it reigages by it self drives fine on flat i have checked the filter all is ok and cooling rad very unusual baffled me
Back to top
View user's profile Send personal message
zocko
*******


Joined: 13 Sep 2009
Posts: 1438
Location: Southampton

PostPosted: Thu Nov 05, 2009 22:40    Post subject: Reply with quote

silly question but is the fluid level correct?
Back to top
View user's profile Send personal message
trigg
Newbie


Joined: 02 Nov 2009
Posts: 3
Location: south wales

PostPosted: Fri Nov 06, 2009 10:26    Post subject: oil level is ok Reply with quote

yea oil level is fine this is what i cant understand thats what makes me think the torque convertor is faulty i have orderd a new fillter just in case
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Gearbox / transmission All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group