4x4 & MPV Driver - 40% subscription discount

Suzuki 4x4 Club™
Dedicated to all Suzuki 4x4 Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
suzuki 4x4 club forumsSuzuki 4x4 Forums   CalendarCalendar  Suzuki 4x4 Club ShopClub Shop  Suzuki 4x4 Classified Ads serviceClassified Ads
Suzuki 4x4 HomeSuzuki 4x4 Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

Freewheeling Hubs


 
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Wheels / tyres / brakes / steering / suspension / chassis
View previous topic :: View next topic  
Author Message
jimnystu
Newbie


Joined: 20 Feb 2008
Posts: 1
Location: Northumberland

PostPosted: Mon Mar 03, 2008 7:56    Post subject: Freewheeling Hubs Reply with quote

Well I went down to KAP and had all the origional type seats put into my Jimny. I made surprisingly good MPG 'blasting' down the A1... Anyway to cut a long story short job well done, so this morning I decided to remove the malfunctioning winch from the front because it seemed like dead weight at the moment, I'll get it serviced another day...

so anyway I was tinkering on with the jimny and I discovered that the freewheeling hubs were all but hanging off it. They'd lost most of their bolts or had become very slack.

I tightened them all back up and completed the job I was doing with the winch bumper, when I came to move off I discovered that the Jimny wouldn't move forward or backward !

So I jacked it up and checked that each wheel would spin and discovered that the 'free wheeling' hubs were far from free wheeling... they pretty much stopped the jimny's front wheels from turning at all untill you slackened the bolts off. So right now it's sitting there with semi tightened bolts while I try and figure out how to put some sort of hub cap over where the free wheeling hubs were and remove the damn things completely.

Oh also one of them gets MEGA hot when you drive anywhere... which would explain the burning oil smell I've been occasionally smelling when I park up somewhere...

I have since discovered from the previous owner that the hubs are fitted because the origional vaccume hubs have been removed, so basically I need to get them to work or I'll have no 4wd.

Does anyone know where I can get them for a a 2000 Jimny JLX ?

Please help ! Many thanks !
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Mon Mar 03, 2008 7:56    Post subject: Google Ads keep this community free to join!


Back to top
Display posts from previous:   
Post new topic   Reply to topic    Suzuki 4x4 Club™ Forum Index -> Wheels / tyres / brakes / steering / suspension / chassis All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group